Author Topic: Driven clutch for a 583 Swap !!  (Read 4004 times)

civic99lx

  • Newbie
  • *
  • Posts: 26
  • Karma: 0
    • View Profile
Driven clutch for a 583 Swap !!
« on: May 30, 2011, 09:52:31 AM »
Hello  ,  i made  a  583 swap  but   i have  a trouble  with  clutch ,  When   is  at Neutral position  and  i  put the trottle  full open  the clutch  Works great , but  when  i  foward the belt stop at 3/4 of Drive clutch and  the  oddy don't go  to  the top of full trottle.
I Have  the TRA Bombardier Drive Cltuch, and  i have the Oddysey Driven clutch . Can   say  your idea about  this  trouble ??

Tanks  A+

N.B. scuse  my writing  i'm french

hoodlum

  • Administrator
  • Hero Member
  • *****
  • Posts: 857
  • Karma: 11
    • View Profile
Re: Driven clutch for a 583 Swap !!
« Reply #1 on: May 30, 2011, 12:31:57 PM »
Quote from: "civic99lx"
Hello  ,  i made  a  583 swap  but   i have  a trouble  with  clutch ,  When   is  at Neutral position  and  i  put the trottle  full open  the clutch  Works great , but  when  i  foward the belt stop at 3/4 of Drive clutch and  the  oddy don't go  to  the top of full trottle.
I Have  the TRA Bombardier Drive Cltuch, and  i have the Oddysey Driven clutch . Can   say  your idea about  this  trouble ??

Tanks  A+

N.B. scuse  my writing  i'm french


Maybe it's not a clutch problem at all...Maybe it's an engine issue...If the engine doesn't rev,the clutch will not fully engage....It could also be that it is shifting out too fast,bogging the engine....
Hoodlum

civic99lx

  • Newbie
  • *
  • Posts: 26
  • Karma: 0
    • View Profile
Driven clutch for a 583 Swap !!
« Reply #2 on: May 30, 2011, 07:03:36 PM »
If  is  the clutch the trouble,   a belt too short it is possible ? or bad clutch setting ? , Because  in the drive clutch the belt make  a  Black line at  the 3/4 of the Clutch and  when  is arrives that brake  the motor and  the  motor can't go  to  full open but  is  only when the  oddy foward, when  it is  at  Neutral position the belt  go at the top  of clutch and  is  ok , is  only when  the  oddy  run foward. The  motor setting  is  OK and it want  to run open trottle, but  is brake at 3/4 because the clutch don't  run great . And  to other  idea  , the Rave Valves  in trouble can make this  too ? It  is  the three idea  i have , but  i doesn't Know  what  is  the  trouble.

 Can  say me  your  idea  about  that ?

tanks A+

hoodlum

  • Administrator
  • Hero Member
  • *****
  • Posts: 857
  • Karma: 11
    • View Profile
Driven clutch for a 583 Swap !!
« Reply #3 on: May 31, 2011, 04:54:13 AM »
Quote from: "civic99lx"
If  is  the clutch the trouble,   a belt too short it is possible ? or bad clutch setting ? , Because  in the drive clutch the belt make  a  Black line at  the 3/4 of the Clutch and  when  is arrives that brake  the motor and  the  motor can't go  to  full open but  is  only when the  oddy foward, when  it is  at  Neutral position the belt  go at the top  of clutch and  is  ok , is  only when  the  oddy  run foward. The  motor setting  is  OK and it want  to run open trottle, but  is brake at 3/4 because the clutch don't  run great . And  to other  idea  , the Rave Valves  in trouble can make this  too ? It  is  the three idea  i have , but  i doesn't Know  what  is  the  trouble.

 Can  say me  your  idea  about  that ?

tanks A+


If it were the belt,the clutch wouldn't shift out in neutral either....I would look at clutch settings.....It sounds like the spring is too stiff.....Are you sure the clutch is compatible with the stock driven as far as the pitch of the faces?
Hoodlum