Author Topic: I'm puzzled  (Read 1179 times)

Smittyg8

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
I'm puzzled
« on: January 24, 2017, 09:09:39 PM »
Bought a 1980 fl250 years ago. When I bought it it was in okay shape need new top end and so on. Had it bored out got a piston and rings and such had much more compression. Trying to start it one day I broke the key way and had to replace it and ever since then it's been a nightmare. I have the electric start and before it would turn over the motor easily and start it. After the new key way the electric start would barely even move it and I mean barely. Took the head off a couple of times to see if anything looked bad. And nothing. Decided to put a compression tester on it today because it feel like it has to much compression and is super hard to pull. With spark plugs in but without it turns good. The conpression tester said it was at 120. So I'm puzzled. If you have any ideas what could be wrong feeel free to drop some knowledge. Thanks

odypilots

  • Sr. Member
  • ****
  • Posts: 344
  • Karma: 6
    • View Profile
    • Downhomeracing.com/opr
Re: I'm puzzled
« Reply #1 on: January 26, 2017, 06:10:24 PM »
I'm no guru, but it sounds like something in the ignition was installed 180 degrees out of sync.
The usual 'my two cents' disclaimer applies. :)

Smittyg8

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
    • View Profile
Re: I'm puzzled
« Reply #2 on: January 27, 2017, 07:47:37 AM »
Even though it has great spark? It could still be 180 off?

odypilots

  • Sr. Member
  • ****
  • Posts: 344
  • Karma: 6
    • View Profile
    • Downhomeracing.com/opr
Re: I'm puzzled
« Reply #3 on: January 27, 2017, 03:17:41 PM »
I believe so.
The usual 'my two cents' disclaimer applies. :)

Rj1

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
    • View Profile
Re: I'm puzzled
« Reply #4 on: May 12, 2017, 12:13:40 PM »
What brand tester were you using .i had a harbor freight comperssion tester  and  I was getting a low reading 100lb with it but trying to pull start it i could tell my comperssion  was not that bad so I bought a snap on tester and my reading was 145lb . And I have the same problem with the Goki starter with the high comperssion it takes a lot of power to start it .