Author Topic: FL250 fuel system/starting question  (Read 969 times)

bashr52

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
FL250 fuel system/starting question
« on: October 07, 2013, 08:29:46 AM »
I finally got the basket case FL250 I've been working on all together last night. It looks good, can't wait to try it out! The Engine has a ton of compression, almost to the point you can't pull it. Since the belt hasnt worked its way into the clutch yet, trying to roll the thing with the spark plug in is impossible, the tires just drag.

Anyway, the thing has been sitting for who knows how long, so to try and prime the system we put a shot of pre-mix into the plug hole. The thing fired right off and ran strong until the mix burnt off. I figured we may have to do this a few times to get the system re-primed, so we did it 3-4 more times. It would fire and run every time until the mix burnt off. You can see gas being pumped though the filter, so I know the pump is working. IF I pull it without priming the system with gas, it will fire once each pull, but will not catch and stay running. When we plumbed the fuel system, we ran from the pump to a T with one fitting going to the carb, the other back to the tank. Looking at the manual though, it shows there should be a pressure valve in the return like to the tank. I do not have one of these. I'm thinking this may be allowing the fuel to just get pumped past the carb and right back into the tank, therefore not filling the bowl?



LiveWire

  • Administrator
  • Hero Member
  • *****
  • Posts: 974
  • Karma: 20
    • View Profile
    • 85 Honda Odyssey FL350 Parts
Re: FL250 fuel system/starting question
« Reply #1 on: October 07, 2013, 05:50:43 PM »
Run the return line up high then back down to the tank and try.