Author Topic: Took the carb apart to clean now high idles  (Read 910 times)

FL350

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
    • View Profile
Took the carb apart to clean now high idles
« on: July 03, 2013, 08:18:58 PM »
Took the carb apart to clean last night on my recently purchased 1987 FL350, put everything back together.  After some priming of the motor (pouring a smidge of gas down the carb) she finally started again.  The motor was reving really really high, it never went back down.  IT seemed that there was a bit of play in the throttle, so I took the carb back off noticed there was ALOT of slack in the cable.  I re-seated the throttle gate in the carb, primed it again and the motor started right up.  The RPMs went down a little bit but it was still at what seemed to be half throttle.  The throttle cable itself isn't too tight I know that much as the throttle has plenty of play.  Any help would be awesome, I just wanna ride.

odypilots

  • Sr. Member
  • ****
  • Posts: 344
  • Karma: 6
    • View Profile
    • Downhomeracing.com/opr
Re: Took the carb apart to clean now high idles
« Reply #1 on: July 04, 2013, 04:44:51 AM »
Had you had the buggy running fine before you did the carb cleaning? Try looking down the air filter end of the carb and make sure the throttle slide is going almost all the way down in the carb. With some carbs, the slide can be clocked 180 degrees wrong, and the slide will hang up and not seat properly.
« Last Edit: July 04, 2013, 04:48:18 AM by odypilots »
The usual 'my two cents' disclaimer applies. :)