Author Topic: help- electrical issue on fl400r  (Read 1175 times)

sdriley

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
help- electrical issue on fl400r
« on: March 16, 2009, 10:11:31 PM »
I have a 1990 fl400r. The battery was low so I hooked the jumper cables to the pilot and my buddy hooked up the cables to his car in reverse. i smelled burning, tried starting it. oops. Then we put it the proper way, the pilot started, runs and idles but it started to accelerate then runs like its flooded or low spark, it doesn't die. What do you think? CDI box damaged? and now the fuel light, reverse light flicker on and to a low dim.

It just happened, any help would be great- thanks

hoodlum

  • Administrator
  • Hero Member
  • *****
  • Posts: 857
  • Karma: 11
    • View Profile
Re: help- electrical issue on fl400r
« Reply #1 on: March 17, 2009, 05:30:27 AM »
Quote from: "sdriley"
I have a 1990 fl400r. The battery was low so I hooked the jumper cables to the pilot and my buddy hooked up the cables to his car in reverse. i smelled burning, tried starting it. oops. Then we put it the proper way, the pilot started, runs and idles but it started to accelerate then runs like its flooded or low spark, it doesn't die. What do you think? CDI box damaged? and now the fuel light, reverse light flicker on and to a low dim.

It just happened, any help would be great- thanks


Dead battery....The battery is sucking all your juice trying to charge....It will flicker the lights when voltage is low....
Hoodlum